Creative Commons License

 

Table of Contents:

 

The rules of thumb in modeling are:

  • Avoid sharp edges smaller than an angle of 90.0001°. Because in some circumstances smaller angles result in slower performance because the model is internally cut into several 3D models at these edges.
    Tip: Bevel these edges to also get a more realistic look.
  • Fewer polygons perform better than more polygons.

 

Metaballs

( aka Meta Objects )

There is a difference between the Properties panel ( N key ) and the Properties Editor ( at the far right ) which is an editor area type.

Metaballs are objects that connect to each other like a fluid when they are close to each other.

Raw Statue

  1. Switch to the Modeling workspace.
  2. Make sure the Viewport ShadingZ key ) is set to Solid.
  3. Make sure the Viewport Mode is set to Object Mode Tab key ).
  4. Use Shift + C to center the 3D Cursor at the origin. The 3D Cursor sets, for example, the position where new objects are created. You can also move objects to the center with Alt + G when you have already created them.
  5. If you want to add a reference / blueprint image to the background:
    1. Switch to the view you want to use to align the background image to, for example, press the Numpad 1 key for Orthographic Front view.
    2. Create a new Collection in the Outliner Editor: Right-click -> Collection: New and name it Background Images and select it.
    3. Open the ( Windows ) File Explorer and drag & drop the image from the File Explorer to Blender's 3D View and rename the image in the Outliner Editor with a descriptive name.
  6. Create a Metaball:
    1. 3D View menu bar -> Add -> Metaball -> select the one you want to add.
    2. Try out a Ball and set its Radius to 15 cm in the Add Metaball window. ( In the lower-left in the 3D View -- you have to click the triangular arrow icon to expand the window. )
  7. In the Properties Editor select the Object Data tab and set Metaball -> Resolution Viewport to 2cm to subdivide the mesh for more detail. The next metaballs you add will inherit this setting.
  8. Create another metaball.
  9. Select a single, unselected metaball by left-clicking the thin, black circle around it.
  10. Duplicate the metaballs if you need more of this kind with Shift + D.
  11. TODO (now Operator panel ?): In Edit Mode ( Tab ) you can subtract a metaball from another metaball. In the Properties Editor  select the Object Data tab -> Active Element -> enable Negative
  12. Now you know the basic keys and commands. Try to create something with the general outlines of an 'abstract statue' that looks interesting. If you need inspiration use a search engine to get some pictures. The size should equal the size of a human.
    Always try to avoid to model "butterflies" which are just mirrored models in the middle. It looks boring and very synthetic. Asymmetrical models look a lot more interesting.
  13. Save the raw metaball project: Blender's menu bar -> File -> Save As... -> MetaballStatue.blend

Metaball Mesh

  1. When you have arranged all your metaobjects of your raw statue convert the objects to a mesh to be able to sculpt them later:
    1. Select all metaballs.
    2. Spacebar -> type 'Convert to' -> select it, then -> Mesh from Curve/Meta/Surf/Text. Once you've converted the metaballs to a mesh you can not convert the mesh back to metaballs. That's the reason why you just saved the raw metaballs file in case you want to edit it or reuse it later.
    3. Make sure the pivot point is at the scene center. If not set it to the center.
  2. Name the statue object Statue in the Outliner Editor with a double-left-click.
  3. Now save the meshed statue's project: Blender's menu bar -> File -> Save As... -> MetaballMeshStatue.blend

UP 


Skin Modifier

The Skin modifier is an alternative and addition to Metaballs to create a basic mesh.

You can for example easily create a stickman model with vertices and add volume to it with the skin modifier and scaling.

  1. Switch to the Modeling workspace.
  2. Create a plane with 3D View -> Add -> Pane
  3. Enter Edit Mode with Tab key.
  4. Select all vertices with A key.
  5. Merge all vertices at the center with Alt + M.
  6. Switch to front view with Numpad 1.
  7. Extrude the vertices several times with E key until you get a stickman.
  8. Add a Skin modifier
  9. Add a Subdivision Surface modifier and set the Viewport Subdivisions to 3.
  10. Switch from Solid Mode to Wireframe Mode with Z key if you want a thicker, more bulky looking stickman just select a vertex and scale it up with Ctrl + A.
  11. Switch to Object Mode with Tab key and apply the modifiers when you're done from top to bottom.
  12. Make sure the pivot point is at the scene center. If not set it to the center.

UP 


Remesh

Remesh to combine several objects like an object created with metaballs and one created with the skin modifier or to relax the mesh.

  1. In Layout workspace, apply the transform for all objects: 3D Viewport menu bar -> Object -> Apply -> All Transforms
  2. Add a Remesh modifier to all the separate objects you want to combine. This will prepare the mesh to work properly with the Voxel Remesh in Blender 2.81.
    1. Select the object.
    2. Properties Editor -> Modifier tab -> Add Modifier -> Remesh
      1. Mode: Smooth
      2. Enable Smooth Shading
      3. Disable Remove Disconnected Pieces
      4. Set the Octree Depth to 6+
    3. Apply the Remesh modifier.
  3. Combine all objects by selecting them and then Ctrl + J to join them and then apply the transforms again.
  4. In Sculpting workspace, use the Voxel Remesh
    1. 3D Viewport menu bar -> Remesh
      1. Voxel Size 0.005 m ( for example )
      2. Enable
        1. Fix Poles
        2. Smooth Normals
    2. Click Remesh to create the new object. The new mesh should consist of around 500,000 triangles.

UP 


Sculpting

In the first step sculpt the rough shape of the statue with rough details. In the next chapter, you'll sculpt the fine details.

Rather don't use the yellow Grabbing Tools in this chapter. Use it in the next chapter with dynamic typology enabled. The dynamic typology will make sure that new polygons are created ( tesselated ) instead of stretching the existing polygons.

You should also disable any Symmetry in the 3D View -> menu bar -> X Y Z.

  1. Center the view at the selected object ( in Object Mode ) with Numpad comma / dot and then hold the middle mouse button to orbit around your statue.
  2. In the Layout workspace set 3D View menu bar -> Object -> Shade Smooth because it is closer to the final shading in the Unity Engine. Then activate Normals -> Auto Smooth with an Angle of 89.9° to sharpen edges and spikes in the Data tab of the Properties Editor.
  3. To hide everything outside an area use Alt + B to select a rectangle. Display all by pressing Alt + B again.
  4. Switch to the Sculpting workspace and start sculpting, optionally with your tablet.
    1. Choose a Sculpt Tool in the Tool Shelf ( T ). One Sculpt Tool can have several Brushes. There are four different categories for Sculpt Tools:
      1. Blue -> Add / subtract volume.
      2. Red -> Increase / decrease contrast.
      3. Yellow -> Grabbing behavior.
      4. White -> Hiding / masking.
    2. Activate Properties Editor -> the Active Tool and Workspace settings tab -> Brush -> Options -> Front Faces Only that the brush only affects the faces pointing to your view. This is helpful if you sculpt very thin / filigrain parts of the model.
    3. Choose a Brush by clicking the brush preview image. You can set its options in the Properties Editor in the Active Tool and Workspace settings tab. You can also right-click in the 3D View to open the context menu.
      And you can create additional brushes by clicking the Add Brush button in the Properties Editor -> Active Tool and Workspace settings tab.
    4. If you use a tablet make sure to activate the pressure sensibility for e.g. sculpting Strength Pressure. In general, I recommend a strength value of 0.25 - 0.75 for rough sculpting.
    5. You can change the smoothing behavior by setting the Brush -> Autosmooth amount. In general, I recommend an Autosmooth value of 0.0 - 0.1 for rough sculpting.
    6. With 3D View menu bar -> Stroke -> Smooth Stroke enabled you can create more steady lines.
    7. To sculpt asymmetrical disable all axis to not mirror the changes made by the brush along the axis in the Properties Editor in the Active Tool and Workspace settings tab -> Symmetry.
      For organic modeling, it's a good move to deactivate this feature to get a natural and asymmetric look at least when you sculpt the details in the next chapter.
    8. Hold the left mouse button to add and Ctrl + left mouse button to subtract volume. Hold Shift + left mouse button to smooth the surface at any time.
    9. Use the Mask brush to exclude areas / polygons that can't be edited when masked. Include polygons you have excluded before with the Shift key. Delete the mask with ALT + M.
    10. To change the brush shape with a curve open the Falloff section of the Active Tool and Workspace settings tab and select a predefined brush curve or create your own.
    11. To smooth the object as a final polishing, use the Smooth brush or simply use the Shift + left mouse button.
  5. When you are satisfied with your raw statue save the project as SculptedStatue.blend.

UP 


Dynamic Topology

In this second sculpting step sculpt the details with Dyntopo ( dynamic topology ). It dynamically adds more detailed geometry to your mesh. You can see this when you switch to Viewport Shading ( Z -> Wireframe.

Dyntopo is automatically turned off every time you leave the Sculpting workspace. You can enable it with Ctrl + D -> OKAnd not all brushes are 100% compatible with dynamic topology, for example, the Layer, Smooth, Grab, Thumb and Rotate brushes. They deform the mesh without to add / subtract polygons uniformly.

  1. Switch to Sculpting workspace.
  2. Enable dynamic topology enabled: Menu bar -> Dyntopo -> Enable Dyntopo or simply use Ctrl + D. Simply confirm the warning because you currently don't care about vertex groups.
  3. Enable smooth shading: Menu bar -> Dyntopo -> Enable Smooth Shading
  4. Check out these settings: Menu bar -> Dyntopo
    • -> Detail Size:
      • Detailing: Relative Detail if you want a brush that creates the topology based on the pixels on the screen. The closer you zoom in the more detail will be added by the brush. The Detail Size is the length in pixels on the screen of the added edges. The lower you set the px value the higher the detail.
      • Detailing: Constant Detail if you don't want a brush that creates the topology based on the pixels on the screen. The amount of detail drawn will remain the same regardless of how close you are at the object. The Detail Size is the number of subdivisions added to the topology. The higher you set the value the higher the detail.
    • -> Dyntopo mode: Sets whether you want to subdivide ( more detail ) or collapse ( less detail ) the mesh. Subdivide Collapse seems to work very well because it combines both methods.
  5. Now you can use the Snake Hook brush to create horns or tails. Dyntopo makes sure that new polygons are created instead of stretching the existing polygons.
  6. To use an image for your sculpting brush shape after you selected your brush: Properties panel ( N ) -> Tool -> Texture
    • + New -> Rename the texture from Texture to SinusExampleBrush.
    • optional: Angle -> Enable Rake if you want the texture always face the movement vector of the brush. This will look more interesting because you can rotate the texture.
    • Switch to the Properties Editor ( at the far right ) -> Texture tab.
    • At the Texture tab open the Image -> Settings and click Open to open this image:
    • Use the Draw brush, set the Strength to 0.3 and the brush's Radius to about 250 px and the Dyntopo's Detail Size to about 2 px.
    • TODO If you use a graphics tablet set the Tool Shelf -> Tool -> Stroke -> Stroke Method from Space to Dots to make it easier to "stamp" the texture to your statue with your pen.
    • You can find a tutorial on how to create your own sculpting brushes in / for Blender in my GitHub project wiki about organic modeling. Find more of my brushes here. Use the XYZFinal.png image files.
  7. To reduce the detail of your model you can use the Simplify ( and then Smooth ) brush with a Constant Detail. Use the pipette to sample the mesh detail in an area where you like the detail of your mesh. ( Switch to Viewport Shading: Wireframe with the Z key to see the mesh. )
  8. To smooth the object as a final polishing, use the Smooth brush. Use the Shift + left mouse button to smooth the surface.
  9. If you want to cover the whole model with one level of detail simply use 3D View -> Dyntopo -> Detailing: Constant Detail -> Remesh: Detail Flood Fill
  10. Play around with all the tools and reload the SculptedStatue.blend project when you are ready to seriously start to improve your statue with more details. And try to sculpt a detailed statue. You should aim for not more than 3,000,000 triangles for your final sculpting model. More would cause performance issues.
  11. Save the project as DetailedStatue.blend.

UP 


Fixing Proportions

The Lattice modifier helps to slightly correct wrong proportions like a too-long arm or a too big head. If you are happy with the proportions you can skip this chapter.

  1. Change to Layout workspace and use Shift + C to center the 3D Cursor at the origin and to zoom.
  2. In the 3D View menu bar create a Lattice: Add  -> Lattice and name it StatueProportions in the Outliner Editor with a double-left-click.
  3. Set the Radius in the Operator Panel on the lower left or in the Properties Editor -> Object tab by scaling the Lattice object that the Lattice object encases your model.
  4. To tweak the resolution of the Lattice in the Properties Editor, select the Object Data tab and change the values of the Lattice -> U, V, and W to e.g. 3 to subdivide the Lattice into more areas for more flexibility. The change in each area affects only the part of the statue inside or very close to this area.
  5. Select the statue object with a left-click in the 3D View and add a Lattice modifier to connect the Lattice object to your model. To do this switch to the Modifiers tab and Properties Editor -> Add Modifier -> Lattice. Now you need to connect the Lattice object to the Lattice modifier to affect the statue with a special Lattice. In the modifier settings under Object: left-click and choose the Lattice object called StatueProportions, you have created earlier, to connect it with the statue.
  6. Select the Lattice and change to Modeling workspace. Enable Proportional Editing and e.g. select Smooth to position more than one vertex. Change the radius of effect / falloff by using the mouse wheel while you position ( G key ) a vertex of the Lattice.
  7. The changes made with the Lattice modifier are not used until you Apply this modifier. Change to Layout workspace and select the statue. In the Properties Editor select the Modifiers tab and click the Apply button.
  8. You can now delete the Lattice object StatueProportions by selecting it and pressing the X key. ( Remember that all commands are confirmed with Enter or left-click. )
  9. Save the fixed statue project as FixedDetailedStatue.blend.

 

If you think this kind of content is helpful, please:

 

UP